[firebase]過去バージョンのダウンロード

firebase は過去バージョンのダウンロードリンクがありませんが、直接 URL を入力することで取得することができます。

https://dl.google.com/firebase/sdk/unity/firebase_unity_sdk_X.X.X.zip

Version 6.16.1 が欲しい場合

https://dl.google.com/firebase/sdk/unity/firebase_unity_sdk_6.16.1.zip

どんなバージョンがあるか確認するにはこちら。

基本的に最新がいいはずだけど…

最新でのみ発生している不具合、という場合が往々にしてあります。
(1~2か月以内にリリースされたバージョンは基本的になんかあるだろう、と思った方が精神衛生上いいかもしれません)

2021/4 現在の最新 firebase7.1 も使った限りは問題ない…ように思えますが、6.16.1 と比較すると、インポート時表示されていたダイアログがまるっと出なかったりします。

7.1.0 で出なくなったダイアログ

「出なくなったのが仕様(正解)でしょ!」と思いたい所ですが、Migrating Packages が出なくなった結果、6.16 では Packages に綺麗に収まったものが、7.1 だと Assets/ に残ったまま。
(でも、最新の Google AdMob では Migrating Packages で綺麗に整理されます。では最新の AdMob と 7.1 の firebase を組み合わせると…?

何が正解かはわかりませんが、バージョンアップしたら急に動かなくなった、という可能性は常に考えておく必要があるでしょう。
Android 系は更新頻度高い分、問題も起こりやすい気が。
また、Unity SDK は問題解決がどうしても後に回されやすい事も考慮しておきましょう。

よろしければ Twitter をフォローしてもらえると嬉しいです!

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA